Error: FDTD multiport when writing input file

Hi support staff,

I'm trying to use Sim4Life Light ..4.4.2 to run a FDTD multiport simulation. I used a coaxial geometry as waveguide port and set excitation as Harmonic.

While when I was trying to click write input file under solver label, it gives me the following error:

Program1.JPG
Program.JPG

The setting is shown as follows:

Settings.JPG

Also when I tried using the script to write input file using WriteInputFile(), it gives the same result:
Script.JPG
But after I directly ran the simulation, and then clear results and write input file, it turns normal.

I repeated the setting on Sim4Life 5.0.0, and it appears the same results.

So I'm not sure how to solve this problem, since my project needs to write h5 input file before I run the simulation.

Hi, Have you tried to run this simulation as "Single FDTD", instead of "Multiport"? You can convert from one type to the other by right-clicking on the simulation and choosing "Clone As" -> "Single FDTD".
I am not sure Multiport simulations have support for waveguide sources (and you have only one such source, so Single FDTD should anyway be what you need).

Log in to reply