Maximum Cell Count

I'm trying to perform the SEFT tutorial on Sim4Life Light.
Tutorials/Acoustic/SEFT.html
When I setup the grid following these steps, I get an error:


1* Click Grid in the Explorer window.

2 * In the Properties window, set Padding Settings to Manual. Specify Bottom Padding as 2.5 mm for all three dimensions by keeping the icon. For the Top Padding, click the to change it to in order to access the settings for each direction individually. Specify 2.5 mm for x and y direction and 30 mm for z direction.

3 * Change Extra Bottom Padding and Extra Top Padding to 1 cell.

4 * Click Auto Grid Update in the ribbon to enable automatic grid updating. An initial grid outline, automatically estimated based on the current model and settings, appears in the 3D window. --------> error: Maximum cell count exceeded

5 * All objects in the simulation project, i.e., “Element”, “Reflector” and “Focus”, have automatically been assigned to Automatic grid settings. The arrowhead to the left of the Automatic Default(3) folder is used to expand the folder. Verify that the Refinement level of the “Automatic” grid settings is set to Default

6 * The total grid size should now be 328 x 328 x 365 = 39.268 MCells and the settings should look similar to Figure 3.7.4


Is this is because I'm using the light version?

The light version of Sim4Life is capped at 20MCells if I recall correctly. So 39MCells won't work.

Is there any changes that I can make to the grid setup to have it simulate without errors?

you could change the maximum step in the automatic grid. Increasing this number will make larger cells thus decreasing the total number. If you play around with this number you can get below 20Mcells easily, however, there is no guarantee that the simulation will give the same results (I have never used the acoustic solver myself...).

Thanks for the insight.
I’m trying to change frequency and period (I’m not sure what period is. Is it the simulation time? Or the cycle?) to get reasonable results.

So you have 2 main stopping criteria in the simulation. 1 is that the simulation has reached a convergence threshold, you can set this too. 2 is the number of periods that the excitation (your ports or input of the simulation) have to go through until you expect the results to be good enough or that it is indicative that the simulation will not converge. Naturally, you would want your simulation to stop by itself due to reaching convergence, but it is good to have the number of periods you're simulating to be around the time it should be converged since that will give you a good time estimate for how long the simulation will take.

This is the time domain solver and we are dealing with acoustic waves that don't travel as fast as light / EM waves. The excitation is a sine wave at a given frequency. To estimate how far the wave will propagate from the source you can calculate the minimum wavelength in each material (speed of sound of the different materials / frequency) and multiply that by the number of periods. You need to make sure that the wave fully travels through the whole domain.

As for the grid question, you should know that the grid resolution is dependent on the frequency for these solvers (for each wavelength - which depends on frequency - there should be at least 10 grid points to have acceptable response). If you are just doing the tutorial I would suggest to lower the frequency and use the automatic grid settings (which automatically calculates the suggested number of cells per wavelength).

@engsk I am having this problem as well. Would love to hear an answer to how adjust the grid setting to continue the tutorial.

I tried to play around with the spacing between cells(offset).
But what worked best was to lower the transducer frequency.
All Depends on your simulation requirements.

Log in to reply