Acoustic Signal Input File

I wish to upload a .txt file representing an acoustic signal and receive the error shown in the image. My signal is truncated to a value less than a single time step in my simulation. So, no input signal is being generated. Why is my input file truncated between 0 and 0.0004 seconds for a 87 second simulation?

8b1ed6ad-b125-4d55-874c-1904649ba83b-image.png

I would need to see your input signal file and your simulation setup, but I best guess would be to look at the 'simulation frequency' in setup. Typically in harmonic simulations, the time step is set based on the lowest wavelength in the materials. It is possible that this is calculated by looking at each material's speed of sound and dividing it by the frequency (set in setup).

Can you maybe try changing this frequency to a higher one (maybe one representative of your input wave form) and see if that fixes your problem? Either way, let me know so I can take a look at the code and make a fix for this in the future. Alternatively, in user defined sources, is there no option for sampling frequency (1/timestep)? That would then be your fix - set the sampling frequency / time step to something that can resolve your waveform.

I am using the SEFT tutorial example. Then, modifying the source to be from an input file rather than a sinusoidal signal. The frequency is 550 kHz and the material is water. The images show the pulse sequence. It represents a signal that is on for 900 ms, then off for 100 ms, and repeats 33 times.

One image represents the entire file. The other is zoomed in to see the on and off portions.

apulse1.png apulse2.png

Really late reply, sorry, hope the reply is still useful ... Please check in 'Setup' what you set up in 'Periods' ... For user defined sources, the simulation time is defined by 1/frequency * periods ... So this might be the issue (which should probably be changed if so)

Log in to reply