'Point Sensor Tool' is not available

I tried using the Point Sensor tool in the Neuron model but it failed and I cannot drag and drop the axon into the Sensor node. I do install NEURON SOFTWARE in Sim4life. The prompt in Consol is shown as the appendix.捕获.PNG

Hi, if you're following the Neuron tutorial please make sure to follow it exactly, there's always a source of confusion there (due to similar names). I don't have S4L in front of me now, but if I recall correctly, you had to go to Sensors, then New Settings then create a new Point Sensor and drag and drop to the created 'subgroup' (not to where it says 'Sensors').

A better and more precise way is to create a point sensor setting under point sensors in the tree. Then drag a trajectory of the axon you're interested in to that point sensor setting. Then open properties window and use the drop-down menu to select the exact node you want. You will see a dot on the axon in the 3D window of the simulation showing you where the point sensor is.

@pheo_zhong so have you solve this problem? please help me.best wishes.

Hi Tina, have you tried following the Neuron tutorial exactly? (There is some confusion in the naming of things as I mentioned in my previous comment - this typically solved it for other people with the same issue)

The other source of issues with this is that you need to make sure you load the neuron model before adding the point sensor

@montanaro thanks for your reply.I have loaded the model .I am trying the neuro tutorial. The point sensor button is gray when I want to set the sensors. So I make a new setting and create a point sensor setting.There is a problem that the run button is gray and I cann't run the solver.

Sorry, don't have S4L with neuron available at the moment, but I looked at the tutorial and it seems to have changed. When you create the sensor settings can you try to drag and drop the axon to the sensor setting and then chose the section name? (That was the old way of doing it)

Still, you should be able to run the simulation without a point sensor.. Sorry can't help more