UNSOLVED FlexNet License Finder pop-up when trying to use Python API in Jupyter

Hello there, I am relatively new to Sim4Life and wanted to start using the Python API via Jupyterlab. After some initial difficulties I got to the point where no Errors would turn up, however a Window called FlexNet License Finder pops up and wants either the Server or license location to continue. I have looked around in the Sim4Life folder but could not find the license file. I am using a student license, in case that is relevant.
The code I am using is:
12ae4dad-7d7a-4fd3-ab4c-f1e4f9ab32d0-image.png

Any help would be very appreciated,
Thank you very much.

Either it's a simple licensing issue (i.e. your license server is somehow unreachable), or what you are doing is simply not supposed to work.
If you are able to open Sim4Life's GUI, it means that your license is valid and I would then opt for the latter.

Here is the "standard" way for using Sim4Life's Python API from a Jupyter notebook:

There should be file called StartNotebook.bat (or similar) in C:\Program Files\Sim4LifeLight_6.2.2.5984. This launches a Jupyter server is configured to have Sim4Life Python kernel as default. All notebooks created or opened from there should be able to use S4L's Python API.

Let me know if that works for you!

@sylvain Thank you for the advice Sylvain! I have tried doing as you suggested and using the StartNotebook.bat does start a Jupyter Server. Unfortunately, if I start a new Notebook and try to import a Sim4Life module, I again get a pop-up called FlexNet License Finder wanting the location of either the license or the license server.
a490c780-3a1d-41ad-a116-8b2c43ada34b-image.png
Just to be sure I have tried doing so on different computers to try and rule out a faulty installation, however the issue persists.
I can confirm that there are no problems with using Sim4Life’s GUI or using the integrated scripter/console. I did take a closer look at the Sim4Life console though and noticed that upon start up the following message is displayed:
8493be54-bcd1-4c7e-ad7d-5abb95b186e3-image.png
So perhaps this is a license issue after all?