P-EM-QS sweeps - can't view results for magneto quasi-static

I'm running simulations to find SAR from a coil in the MIDA head model. The workflow is:

  • Solve magneto static vector potential from the coil (SV).
  • Use the field sensor settings from this simulation as the source for a magneto quasi-static simulation on the head model (QS), solve the QS model.

If I run these simulations manually then I can extract the sensor for the overall field from both the SV and QS simulations and use the slice viewer etc. If I do a sweep of just the SV simulation, changing the coil position relative to the head, then I can again extract the overall field sensor and generate plots etc. for each iteration.

My problem is when I try to sweep the QS simulation. The iterations all solve according to task manager, but when I try to actually view the data (using the slice viewer) I get these error messages:

  • Analysis [Error] SAR(x,y,z,f0) (Iterated) - Slice Viewer: Failed to compute output attributes
  • Analysis [Error] Failed computing data. Auto Apply unchecked
  • Analysis [Error] SAR(x,y,z,f0) (Iterated) - Slice Viewer: Could not update attributes
  • Analysis [Error] Unable to create SAR(x,y,z,f0) (Iterated) - Slice Viewer

Does anyone know how to fix this?

I've solved the issue. The sweep works if I set the source for the QS solver to a coil (wire current settings) instead of linking in that data from the SV solver (vector potential settings).