"Poin Senson Tool" option not available for Monopole stimulation in Neuronal Dynamics Solver.

Hello there,
I am using the tutorial for Monopole Stimulation in the Neuronal dynamics solver in sim4life light. Although I followed step by step the instructions (more than once, just to make sure) every time I reach into the "Sensors" setting, at [ Simulation Settings (Neuron)]....the option "Point "Sensor Tool" in not available to click into.
Here is a screenshot..0_1540318897288_Screenshot.png
Also, in the tutorial for the Monopole Stimulation the settings "Point Processes" and "Network Connections" doesn't exist unlike their existence in the actual program.
Any help would be useful,

Thanks in advance,


Not sure if that's related, but did you install the Neuron solver? This is a separate installer and it is needed for Neuron simulations to work through so you will need it anyway.

Thanks for the immediate response,
I have downloaded the NEURON by Yale University. Do I have to insert the folder of NEURON into any specific folder of sim4life light or anything else, to activate it ? Cause I tried again the tutorial and it still not giving me the option of "Point Sensor Tool".
Other than that, you can't see any other reason why it is doing that....right?

@christos1996 Hi, you need to install the neurons4l in the installation folder of Sim4Life. You can check that the process succeeded by verifying that a folder neurons4l is created in that folder.

However, I also see that the problem can also be different. It seems that you haven't still load the model, therefore the Point sensor option is still not accessible. To do that, press on the 'Load Model' icon in the same tool bar.

Just near the Point Sensor Tool, there is another icon (New Settings). There you can create as many point sensors or line sensors as you like. Then you need to drag and drop the neuron/axon entity from the modeler to the setting and there select the section at which you desire to attach a sensor.

Concerning your other comments: a) Point Processes and Network connections are not included in this tutorial once not needed. This tutorial shows you how to couple EM simulations to a single fiber model. Point processes (e.g. current clamps) can be assigned using the very same procedure just described for Point Sensors (New Settings -> IClamp the drag and drop you axon entity into the Point Process Settings in neuronal simulation, and assign parameters in the Properties panel).

Concerning b) network connections are as well not described here once the model do not include any network. My suggestion is that you read the tutorial for the "Neuronal Networks and connections".


@antoninomc Hello and thanks for your time and all of the information,

I don't think that my problem is associated with the model not been loaded, cause I 've tried to load it various times (even before I start this topic) with various different models and the option Point Sensor Tool is still not available. {When I press "load model" nothing happens....is that normal?}

As for the (New Settings) -> Point Sensor option, i have tried it various times as well and it seems that dragging and dropping the neuron/axon into the "Point Sensor Settings" is prohibited. Here is a screenshot :

Also, I do understand why Point Processes and Network Connections are not needed for this EM Stimulation tutorial and my question was referred to their absence in a screenshot that I saw when I was reading the tutorial. But that 's not my major concern right now.

If it helps I tried to complete the Neuronal Networks and Connections tutorial and the same problem appears when I reach into the Sensor Setting, in which after I select New Settings -> IClamp …...and drag my axon from the modeler, I can't drop it into the Point Process Settings (same as in the EM stimulation).

Lastly, I did download again the NEURON from Yale and installed it in the sim4life light folder. The name of the installed folder isn't neurons4l but "nrn" . Is it the same ? Cause if it is, then that wasn't the problem cause I still can't put sensors on axons in any of my models.

Thanks in advance,

Dear @Christos1996
I see here the main problem, and is the fact that the model is still not load. If nothing happens, there is a error 😉 In the top panel, got to View->Console, so that you can see what error message you get when you click on 'Load Model'. Try to do that and post me the result..

Hello @antoninomc,

The problem was indeed the model not been loaded.
That was because i didn't have neurons4l installed.
I installed neurons4l into the Sim4lifeLight_v4.2 folder but when i try to load the model i get this message :
I0_1540927962937_2018-10-30 (1).png
0_1540849008590_2018-10-29 (4).png
Let me know if you have any ideas,
Thanks in advance.

Sorry, as a clarification, how exactly are we supposed to install neurons4l on Sim4LifeLight V Is there a link to a download site that you can provide or a specific process?

@prithn Yes, there is a link to the downloads. It's all on the zmt website, actually, but it's not obvious that you have to look here.
Hope this helps.

This post is deleted!

I am having the same problem, though I've installed Neuron I am running the full version of SIM4LIFE

"Error : too many positional options have been specified on the command line" is written in the console similar to @Christos1996

@AntoninoMC do you have any ideas how to get the point sensor tool to become available?

@jeantoul hi, that message is not related with the T-Neuro functionality, therefore the error has to be somewhere else. Is the axon trajectory a spline entity? Have you created it or was it provided in the tutorial? If you are running the tutorial, are you using the Python interface access to the tutorials or have you loaded the Sim4Life project of the Monopole tutorial and just run the NEURON simulation provided in the project? Could you try to create the NEURON simulation from scratch?

@christos1996 when I reach into the "Sensors" setting at Simulation Settings (Neuron)], the option "Point "Sensor Tool" is not available to click into. I am sure I have load the model. So have you solved this problem? how to solve ? hope you can reply me .