voxel of individual anatomic model creates holes

I created my own anatomic model based on a patient CT data set. I have different Roi´s made by a doctor and fat, muscle and bone is created with threshholding software. At the end of process i have a anatomic voxel model without any empty spaces ( double checked it with "Amira"-software and iSeg) I import my model to Sim4Life and do the voxeling process. After that I get irregular holes ( properties like the background) in my model. Small and big holes in different Roi´s, not only in every slice. I tested a smaller and a bigger Gridsize and other models, same problems.
Is there a for my problem? Or is it possible to load only voxels without the process "create triangles to meshes"?

Pic A There is no Fat (yellow in some regions). you can see that there are no Voxels (pic B)
Pic C Everything is filled with Fat (yellow), Muscle (red) Bone (white) and doctors´s Structures, but in the next slice (Pic D) there are holes (grey)
Sim4life1.jpg
Sim4life2.jpg

How do you import the segmentation into Sim4Life: By loading the iSEG project file (*.prj) or via Import Voxels (with the option "Create Solids" on or off)?

If you are importing voxels, I would recommend to select "Create Solids" = OFF. Then, since you cannot directly assign the imported label field to a simulation, generate a surface-based model (Image Tools -> Generate Surfaces).

Also, try to avoid create surfaces of different tissues separately, or post-processing them separately, if possible. The Generate Surfaces tool creates a solid model with no holes, gaps or overlaps.

I cannot guess where the issue in C/D is coming from, except that the voxeler is having problems with the solids (if you selected "Create Solids"=ON in the voxel import dialog).

Did it help? Else i would be glad to try some other suggestions

Log in to reply